fix installdeps for OpenSUSE Fix syntax error (calling functions from the wrong script) and add openal-soft-devel to deps. link

rkitover authored to master